
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
click2try™ Tutorial 

 

Joomla!



Copyright © 2008-2009 Presage Technologies, LLC. 

You may freely distribute or publish this content provided you publish the content in its 
entirety and include all existing copyright notices, attributions, links, and acknowledgements 
to click2try™, Presage Technologies, LLC. and to organizations mentioned explicitly or 
implicitly herein. 



Joomla! 

 

 ©2008-2009 Presage Technologies, LLC.                        3  

 
 
 
 
Contents 
 
Introduction .....................................................................................5 

Logging In to Joomla! .......................................................................5 

Logging In to the Administration Control Panel ................................7 

Modifying the Template ..................................................................10 

Adding a New Article ......................................................................11 

Editing the Top Menu ......................................................................12 

Removing Unnecessary Modules .....................................................13 

Communicating with Other Users....................................................14 

Archiving Content ...........................................................................15 

Resources .......................................................................................16 

 
 
 
 



Joomla! 

 

 ©2008-2009 Presage Technologies, LLC.                        4  



Joomla! 

 

 ©2008-2009 Presage Technologies, LLC.                        5  

 

Introduction 

Joomla! is an advanced and easy-to-use content management system that 
allows you to design, develop, and deploy a Web site in under an hour. The 
template-driven architecture of Joomla! gives you control over the look and 
feel of your site, and hundreds of free and commercial plug-ins provide 
enhanced capabilities, such as forums, shopping carts, themes, news feeds, 
and much, much more.  

If you want to create and host any kind of Web site, whether it’s a 
commercial site, fan site, social networking site, news site, entertainment 
site, or any combination of those sites, Joomla! can help you 

You’ll need at least a little familiarity with Joomla! before you’ll be able to 
build your site, but after working through this short tutorial, you should have 
no problem setting up your first site. When setting up your site, you’ll want 
to: 

• Sign in to the Administration control panel 
• Modify the standard Front page template  
• Add a new article  
• Edit the Top Menu  
• Remove a few unnecessary modules  
• Change the Logo graphic  
• Add new Newsflash content. 

 

Logging In to Joomla! 

When you first start the click2trytm Joomla! Appliance, you’ll see the Joomla! 
Front page. This is an example of what your website visitors will see when 
they come to your Joomla!-based site. Of course, right off the bat, it has a 
lot of information about Joomla! You’ll want it to reflect your own business or 
interests. To get started making your important modifications to the Joomla! 
interface, you’ll need to log in. 

To sign in: 

1. Enter your click2trytm username in the Username field. 
2. Enter your click2trytm password in the Password field. 
3. Click Login. 
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This redisplays the Joomla! Front page. You should see a greeting down on 
the lower left side of the page, where the Login form was located. It will say 
something like “Hi John Doe,” followed by the Logout button.  

The Front page consists of several content modules. You can modify and 
remove those modules, and add other modules. Review the screen graphic 
below to become acquainted with the different modules. 
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Logging In to the Administration Control Panel 

The Administration Control Panel is where you manage the back-end 
operations in Joomla! Including setting up users and permissions, changing 
the look-and-feel of the site, adding content, and so on. 

To login to the Administration control panel: 

1. Click the Admin tab at the top of the click2try™ appliance. This 
displays the Administration Login page. 

2. If not already filled in, enter your username into the Username field. 
3. Enter your password into the Password field. 
4. Click Login. This displays the Administration control panel. 

The Administration control panel contains a number of large icon buttons. 
Each button represents another area within Joomla! where you can define 
and configure content, users, menus, and more. Keep in mind that 
everything in Joomla! is stored in a database. The different Managers 
described in the following table are like windows or directories, revealing the 
files and data within your database. Here’s a brief description of each button 
and what it controls. 
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Button Icon Description 

 

Displays the New Article page, containing a 
WYSIWYG editor, parameters and advanced 
parameters editors, and a metadata editor. You can 
set various parameters for your article elements, such 
as author name, date authored, and public or private 
access. You can also set global or local parameters for 
article elements, such as title, intro text, article rating, 
and more. In the Metadata Information editor, create 
an SEO-ready description, keywords, and specify a 
robots.txt file, if needed. 

 

Lists all articles currently in your Joomla! database. 
Includes details such as publication date, author, 
category, section, order of appearance, and more. 
From here, you can also delete or reorder articles. 

 

A subset of the Article Manager, the Front Page 
Manager shows which articles appear on the Front 
Page, when they were published, the order of 
appearance, author, section, and category. From this 
page, you can remove, reorder, publish, unpublish, 
and archive articles appearing on the Front Page. 

 

Think of sections as containers, organizing broad 
groups of content types. In a hierarchical structure, 
the sections are the major branches within the site. 
You might have an About section, a News section, a 
Products/Services section, a Pricing section, a 
Community section, and so on. Within each section, 
you can create numerous categories. 

 

You can assign each article you add to Joomla! to a 
category to help you and your site visitors sort and 
locate different articles. For example, in your About 
section, you might create categories like Our 
Company, Our Mission, and Contact Us. A News 
section might contain categories like Local News, 
National News, International News, Product News, 
Company News, and so on.  
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Button Icon Description 

 

The Media Manager helps you keep track of all of 
your graphics, videos, audio files, and any other files 
that aren’t just text content. For example, you might 
want to create categories in the Media Manager for 
banners, logos, emoticons, or other graphic elements.  

 

The Joomla! interface contains several menu objects 
that you can modify to personalize the site to your 
needs. In addition to the main menu, Joomla! also 
provides a user menu, top menu, resources menu, 
example pages menu, and key concepts menu. You 
can also create your own menus. The Menu Manager 
lists all of the current menus, their types, and links to 
menu item editors.  

 

The Language Manager displays the current default 
language for your site and lets you add additional 
language support. 

 

The User Manager lets you create and manage users 
to your Joomla! site. You can define user roles, which 
confer different permissions and access levels to 
users, and you can monitor the current user status. 

 

The Global Configuration pages enable you to 
configure your site, system, and server. This means 
that you’ll be able to easily set everything from time 
zone to FTP, database, and email settings, as well as 
allowable media types and sizes, initial user settings, 
keyword and SEO settings, site name, and much 
more. 
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Modifying the Template 

Templates let you quickly and easily modify the look-and-feel of your Joomla! 
site. Templates manage presentation details, such as colors, graphics, and 
the placement of content modules. You can create your own template, or 
there are literally thousands of free templates provided by the dedicated 
community of Joomla! users. The standard Joomla! installation comes pre-
loaded with three templates. One of them is the Milkyway template that you 
see when you first start up the click2try™ Joomla! appliance.  

Let’s change the template to see what happens. 

To modify the template: 

1. From any page in the Administration Control Panel, select the 
Extensions menu from the Main menu. 

2. Select Template Manager. This displays a list of three templates. 
3. Select the beez template. 
4. Click the Default star icon. 
5. Click Preview to open a new tab or window to see what the new 

template looks like. 
6. Go back to the Template Manager page and repeat those steps with 

another template. 
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Adding a New Article 

In Joomla! an article is any written or textual content you add to your site. 
Search engines love sites with lots of original, useful content. So, it’s helpful 
to create or purchase lots of relevant content before you launch your site. 
You see, search engine spiders, the small programs that crawl over the Web 
indexing pages, only come around once in a while. So, if your site only 
contains one article for weeks, well, you’re not going to be ranked very 
highly in the search engines. On the other hand, if you launch your site with 
dozens or even a hundred or more articles about your topic of interest, the 
search engine spiders are much more likely to see your site as an authority 
site and give you a higher ranking. 

To add a new article: 

1. On the Administration Control Panel, click the Add New Article 
button. 

2. Enter a title. 

3. Enter an alias. Don’t include spaces or special characters in the alias. 
Just create a short alias that will help you remember what the article is 
about. 

4. Select FAQs from the Section drop-down menu. 
5. Select General from the Category drop-down menu. 
6. Above the Category drop-down menu, make sure that both Published 

and Front Page are set to Yes. 
7. Click in the edit window and enter your content.  
8. If you want, style the content using the format buttons at the top of 

the edit window. 
9. Click Apply. 
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10. Click Save. This takes you to the Article Manager. 
11. Click Preview to see what your page looks like. 

If you want, you can edit existing sample articles in the Article Manager, 
changing only the title, alias, and text, and Joomla! retains the current 
formatting of the article.  

Editing the Top Menu 

The Top Menu is the standard navigation menu that most of us are familiar 
with on Web sites and blogs. It’s that menu bar that often runs horizontally 
across the top of the page and contains links to the About page, Product or 
Service pages, FAQs, and other general topics. It’s also one of the menus 
that people most often want to modify on their own sites. 

The sample Joomla! site has a Top Menu that contains an About Joomla! 
menu item. Let’s change that to About Us. 

To edit the Top Menu: 

1. From the Main menu in the Administrative Control Panel, choose 
Menus > Top Menu. 

2. Click the About Joomla! menu item. This opens the Menu Item 
editing page. 
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3. Change the title from About Joomla! to About Us. 
4. Change the Alias from “about-joomla” to “about-us.” 
5. Click Apply. 
6. Click Save.  

7. Click Preview. You should now see About Us in the top menu.  
8. You can now change the other Top Menu items, if you like.   

Removing Unnecessary Modules 

Joomla! comes pre-loaded with all sorts of modules, just in case you might 
want to use them. But, sometimes it’s easier to remove some of those 
modules and then add them back in as you need them. Modules take up 
space in the database and must be managed. If you’re not using them, 
there’s no point in keeping them around. 

Here’s a screen shot of the Module Manager, with all of its modules. 

To remove modules: 

1. Select Extensions > Module Manager from the Main menu. 
2. On the Module Manager, click the green checkmark icon beside each 

module you want to remove. For example, click the green checkmark 
icon next to the Key Concepts and Polls modules. When you click the 
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green icon, it turns to a red x icon, showing that the item is now 
disabled. 

3. Click Apply. 
4. Click Save. 
5. Click Preview to view the Front page without the modules. 
6. If you want to return the module to the page, just click the green 

Apply icon next to the item. 

Communicating with Other Users 

Joomla! provides a simple but effective messaging system that lets you 
communicate with registered users of your site. You can also send mass mail 
messages, if you want to send a global notification, for instance, for 
scheduled maintenance, holidays, or special programs. 

To communicate with another user: 

1. From the Main menu, select Tools > Write Message. 
2. Select the user you want to contact from the To: drop-down menu. 
3. Type a subject line. 
4. Type a message. 
5. Click Send. 
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To send mass email: 

1. From the Main menu, select Tools > Mass Mail. 
2. In the Details area, select the options you want. 
3. Select which group or type of user you want to mail. 
4. Type a subject line. 
5. Type your message. 
6. Click Send. 

That’s all there is to it!  

Archiving Content 

There will come a time when you want to archive individual articles. You 
don’t want to delete them, as they provide a body of information on your site 
that may be valuable for your users and visitors. But you may not want 
certain articles to continue to appear on the front page forever. Most content 
has a certain shelf life and to make sure you continue to attract an audience, 
you’ll want to refresh your site with new content from time to time. 

It’s very easy to archive your content. When you archive an article, Joomla! 
saves it in the database and marks it as archived. You can always find 
archived articles in the Article Manager, with a label of [Archived].  

To archive an article: 

1. From the Main menu, select Content > Article Manager. 
2. Select the checkbox next to the articles you want to archive. 
3. Click the Archive icon. 
4. To unarchive an article: 
5. From the Main menu, select Content > Article Manager. 
6. Select the checkbox next to an archived article. Look for the 

[Archived] label next to article titles. 
7. Click the Unarchive icon.  

Just because an article is unarchived doesn’t mean it’s published again. It 
just means it’s available. If you want to publish the article, select the 
checkbox next to the article and click the Publish icon.   
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Resources 

While this tutorial should have helped you get more familiar and comfortable 
navigating Joomla! and making changes in its Administrative control panel, 
it’s not meant to make you an expert. If you want to learn more about 
Joomla!, go to the resources listed in the Resources section of our Joomla! 
page, and spend some time with these resources. 

Joomla! http://www.joomla.org - Main Joomla! site for all things Joomla! 

Joomla! Community http://community.joomla.org - Main Joomla! 
community site, where you can find tons of great user-supplied information, 
and get to know other Joomla! lovers. 

Joomla! Wikipedia Entry http://en.wikipedia.org/wiki/joomla! - Excellent 
overview and lots of links to useful sites. 

Joomla! Tutorials 
http://www.joomlatutorials.com/joomla_tutorials/joomla_1.5_tutorials.html - 
Some very good tutorials here on Joomla! details. 


